Arquivo da tag: Ruby 1.8.6

Encerrada a produção do Ruby 1.8.6

Em maio de 2009, a empresa de hospedagem de aplicativos Engine Yard assumiu a manutenção do Ruby 1.8.6, o ramo mais antigo da linguagem Ruby. A intenção era fornecer segurança e correções de bugs para a versão. Agora, quase dois anos e meio depois, a companhia anunciou que vai encerrar o suporte. Kirk Haines, da Engine Yard, que liderou a manutenção para o 1.8.6, anunciou em julho, no RubyKaigi, que após mais um lançamento, dentro de dois meses, não vai mais suportar essa versão.

O Ruby 1.8.6 foi lançado originalmente em março de 2007. A Engine Yard diz que nenhuma ação é necessária por parte de seus clientes e aconselha que os usuários do 1.8.6 devem considerar as versões 1.8.7 ou 1.9.2. Ela observa, porém, que 1.8.7 está prevista para entrar em manutenção “support only” no verão de 2012, e que eles mudaram para o Ruby 1.9.2 como versão padrão.

Texto citado originalmente de TheH

Fonte: IMaster